Amazon E-Commerce Service 4.0

Amazon E-Commerce Service 4.0
AmazonのWeb Serviceなんだが、ruby1.8.1(とそれについてるsoap4r)でやろうとしたらwsdlをパースできんかった。3.0ならできそうなんだが(この場合もsoap4r1.5.2が別途必要みたい)。SOAPのバージョンかもしれん(soap4rはSOAP1.1対応)。
→ コメントいただきました。soap4rは現時点でAmazon E-Commerce Serviceには未対応だそうです。

まあRESTでもできるようなのでそれでやるか….ふにゅ。